Jump to content
TorGuard

Recommended Posts

As far as I can tell, the IOS application is either unreliable in maintaining a solid connection with a VPN, or there is an intrinsic issue using a VPN tunnel with mobile. 

The reason I say this is because at random intervals of time, I notice that my VPN tunnel is no longer connected. I'll open the app, and the connection time will show 00:00 even though the VPN status bar on my phones notification tray is still "active". That being said, once I have reopened the TorGuard app, the connection time once again starts counting. 
This tells me that for a duration of time, my tunnel was not active, and not running in the background even though I started it. This certainly does not inspire peace of mind. 
Now, my question is this- 
Is this a result of a bug in the application? Is it a feature meant to save mobile data? Or is it a result of the phone potentially losing connection to its tower or wifi while roaming about and the tunnel closing? I'd love a response from the developers, and possibly a way to counter this in an update. For those of us who have unlimited data and want peace of mind full time, I can say I'd like to have my VPN "always on". 
Attached is an image of my TorGuard IOS application. This screen capture shows me having just opened TorGuard while it was running in the background. Before opening the app, the VPN icon was still showing up on the top bar, indicating the VPN is active. However, the connection timer is at 00:00. 
Very respectfully, 
-Kerry 

Torguard mobile.jpg

Share this post


Link to post
Share on other sites
On 05/07/2018 at 7:38 PM, Kerry said:

As far as I can tell, the IOS application is either unreliable in maintaining a solid connection with a VPN, or there is an intrinsic issue using a VPN tunnel with mobile. 

The reason I say this is because at random intervals of time, I notice that my VPN tunnel is no longer connected. I'll open the app, and the connection time will show 00:00 even though the VPN status bar on my phones notification tray is still "active". That being said, once I have reopened the TorGuard app, the connection time once again starts counting. 
This tells me that for a duration of time, my tunnel was not active, and not running in the background even though I started it. This certainly does not inspire peace of mind. 
Now, my question is this- 
Is this a result of a bug in the application? Is it a feature meant to save mobile data? Or is it a result of the phone potentially losing connection to its tower or wifi while roaming about and the tunnel closing? I'd love a response from the developers, and possibly a way to counter this in an update. For those of us who have unlimited data and want peace of mind full time, I can say I'd like to have my VPN "always on". 
Attached is an image of my TorGuard IOS application. This screen capture shows me having just opened TorGuard while it was running in the background. Before opening the app, the VPN icon was still showing up on the top bar, indicating the VPN is active. However, the connection timer is at 00:00. 
Very respectfully, 
-Kerry 

Torguard mobile.jpg

 

Hi Kerry,

That is very odd indeed, i can't say i have seen this before, what version of iOS are you running? what options are enabled under settings? for the sake of trying to reproduce.

If the VPN icon is visible then rest assured you are connected, of course when using on-demand this can come and go depending on your usage, the best way to tell if you have been disconnected and reconnected is that your local IP would change, if this is still the same before and after this happens then you can be sure your VPN did not disconnect and there's something triggering odd behaviour with the timer..

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×