Jump to content
TorGuard
  • 0
Support

TorGuard Client v3.86.0

Rate this question

Question

======================================
TorGuard v3.86.0 Release
======================================

ChangeLog:

* All platforms: Optional "Still Active" warning

 When TorGuard is closed while the VPN is
 still running, a warning is shown.
 The warning can now be disabled in Settings -> General

* All platforms: new DNS added

 Quad9 and Cloudflare are added to the DNS list.

* Windows: Remove hidden interfaces from the list

 Windows uses internally "simulated" network adapters.
 These adapters are for internal tasks and should not be modified.
 It could happen that the user can see them inside TorGuard,
 and they are recognisable since they have characters normally
 forbidden for an interface name, for instance: \/:*?<>|"
 We now filter out interfaces with invalid names.

* Windows: TaskScheduler kill TorGuard after 3 days

 The default behaviour when creating a scheduled task in Windows is
to kill it if it runs longer than 3 days.
 The users that used "Auto start on boot" option, could have TorGuard
 killed after the third day.
 The bug is solved with this patch, and we manually unset the time limit.

* MacOSX: Bundle signature fixed

 The bundle signature was broken if the option
 "Hide Icon from Dock" was used. The problem is fixed with
this patch.

Internal Changes:
-----------------

* All platforms: Build process improved

 The new improvement will reduce the risk of bugs
 in the build process of TorGuard

* MacOSX: MacOSXUtilities security improved

 MacOSXUtilities is an important feature used in MacOSX.
 Due to its importance, we are constantly improving its security.
======================================

Downloads

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Every since upgrading to this latest version, the client seems to disconnect randomly, and give me the username / password combination is incorrect. I have installed the previous version of 3.85 to test. Running OSX 10.13.5 have never has this issue until this version.

Share this post


Link to post
Share on other sites
  • 0

I'm on Windows 7 SP1 and I'm having the random username/password disconnect issue too. I'm also having a problem where if I use TorGuard then put my computer to sleep (after properly disconnecting, of course) it'll freeze when I try to wake it up and I'll have to hard shutdown.

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, ondrovic said:

Every since upgrading to this latest version, the client seems to disconnect randomly, and give me the username / password combination is incorrect. I have installed the previous version of 3.85 to test. Running OSX 10.13.5 have never has this issue until this version.

 

The problem was fixed, it was a network issue sorry.

6 hours ago, sm90 said:

I'm on Windows 7 SP1 and I'm having the random username/password disconnect issue too. I'm also having a problem where if I use TorGuard then put my computer to sleep (after properly disconnecting, of course) it'll freeze when I try to wake it up and I'll have to hard shutdown.

 

this is now fixed posting new release here shortly.

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×