Jump to content
TorGuard
  • 0
Bpeopi

No internet connection when VPN is disconnected

Rate this question

Question

I'm having trouble where I cannot connect to the internet when my VPN is disconnected. 

When I am connected, I have internet. 

Any suggestions on what to check and what to do?

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 1

I have the same problem (running Mac OS). I have no connection to the internet unless Torguard is running; if Torguard is running (regardless of whether I am connected to a VPN or not) I can access the internet fine.

I followed the suggestion above (setting DNS to "Level3") and it didn't work. I also tried the LiveChat earlier and it suggested another set of instructions (setting DNS to "open dns" and "enable dns state recovery at start" to "no") and that didn't work either.

Any other suggestions? 

Share this post


Link to post
Share on other sites
  • 0

I'm having this exact issue. I just updated my Mac OS to 10.13.3. The support chat person told me to reset my TG settings to default, but this problem remains even if I quit the application or restart my machine... 

Share this post


Link to post
Share on other sites
  • 0

Hello,

Please go to more settings --> Network Tab --> Set the DNS as below:

At Application Start: Level3
While establishing: Level3
When VPN is connected: Level3

Restart TG Client and retest.

Let me know if this resolves your problem.

Regards

  • Confused 1

Share this post


Link to post
Share on other sites
  • 0

Hey guys

Can you let me know the output of 

netstat -rn

Once when torguard is connected with seamless reconnect and once when disconnected and closed, you can PM them to me,

Thanks

Share this post


Link to post
Share on other sites
  • 0

Hello, Mike from support helped. . it worked for me. 

I did TWO changes in settings:   One on my Macbook network settings, one under Torguard settings

 

 

Goto your macbook  Settings --> Network ---> Advanced ---->DNS------>  Type + then 192.168.1.1 into list of DNS servers, click ok (or Apply).

 

Next open  Torguard and go to  "More settings" at bottom of login screen then click NETWORK, and almost down entire page, under DNS you will see option stating  "-when VPN is connected" and then a drop down box to right to select things. . .  I did also change the setting  to "Google", then saved and closed.

 

REbooted and tried, and voila. . . so far.  Can connect to internet without launching torguard again.

 

Hope this works for you, it did for me.  

Share this post


Link to post
Share on other sites
  • 0

Hi guys:

I seem to have solved the problem, but I don't know how. This is what I did:

-reset Torguard to default settings

-restarted Torguard

-restarted my Mac

I've done these three things previously without any effect, but the one thing  different this time was that I prevented Steam from auto-starting at login. I'm not sure whether this was what made the difference, but it might have, since its the only thing that has changed. I'd be curious to hear if other people who've had this problem also had apps that started up upon login that might have been the cause.

After resetting and restarting, I've tested my access to the internet in all three conditions (Torguard on but VPN not connected; Torguard on and VPN connected; and Torguard off). I've been able to connect in all three cases.

Not sure what happened there, just glad the situation resolved itself.

Share this post


Link to post
Share on other sites
  • 0

Guys we have found the issue (we think) - under more settings --> network --> "Enable DNS recovery state on start" if this is set to "forget information" and your client closes for any reason without first disconnecting (as when users update) then our local endpoint DNS will be left on your interface leaving you with no DNS connectivity, we recommend you first disconnect while updating but we also recommend that you do not set "forget information" and set to auto recover to restore dns to it's original state while closing or crashing for any reason.

Regards

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
On 2/1/2018 at 2:26 PM, Support said:

Hello,

Please go to more settings --> Network Tab --> Set the DNS as below:

At Application Start: Level3
While establishing: Level3
When VPN is connected: Level3

Restart TG Client and retest.

Let me know if this resolves your problem.

Regards

This worked for me thanks. 

-running TG 0.3.78   on a Mac OS high sierra 10.13.3

Share this post


Link to post
Share on other sites
  • 0
On 2/6/2018 at 6:43 AM, Support said:

Guys we have found the issue (we think) - under more settings --> network --> "Enable DNS recovery state on start" if this is set to "forget information" and your client closes for any reason without first disconnecting (as when users update) then our local endpoint DNS will be left on your interface leaving you with no DNS connectivity, we recommend you first disconnect while updating but we also recommend that you do not set "forget information" and set to auto recover to restore dns to it's original state while closing or crashing for any reason.

Regards

 

Hi Support, 
Actually this solution only partially improved my situation. I can now connect to the internet but only if the Torguard Client is open ( an active VPM connection is not needed to go online)> Please help.  

Share this post


Link to post
Share on other sites
  • 0
59 minutes ago, Cereal&Milk said:

 

Hi Support, 
Actually this solution only partially improved my situation. I can now connect to the internet but only if the Torguard Client is open ( an active VPM connection is not needed to go online)> Please help.  

 

Hey there, please see here >> https://torguard.net/knowledgebase.php?action=displayarticle&id=125

Set the DNS to either Google or level3, let me know if that works.

Regards

Share this post


Link to post
Share on other sites
  • 0

Hey, just to add something. I've had the same problem and it was indeed the DNS that caused it. I already had "Enable DNS recovery state on start" on auto recover, but that didn't help. Setting my DNS to Google in the Mac OS system settings finally solved it. But I had to change the DNS settings while the TorGuard process didn't run, so even if I wasn't connected to a VPN connection and changed the settings, it would reset it again after closing the TorGuard process. So make sure you exit TorGuard completely before setting the DNS to Google

Share this post


Link to post
Share on other sites
  • 0

To solve this issue go to System Preferences >> Network >> click your interface on left and click advanced, click DNS >> remove any DNS you see here by clicking the - at the bottom.
 

Everything should now be back to normal.

Regards

Share this post


Link to post
Share on other sites
  • 0
On 2/1/2018 at 1:26 PM, Support said:

Hello,

Please go to more settings --> Network Tab --> Set the DNS as below:

At Application Start: Level3
While establishing: Level3
When VPN is connected: Level3

Restart TG Client and retest.

Let me know if this resolves your problem.

Regards

Forgive me for such a dumb question, but I'm trying to resolve the same problem on my MacBook - but for the life of me I can't find "more settings" anywhere on my TorGuard app? Not in the menu or on the app space itself.

Help?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, anthonywrites said:

Forgive me for such a dumb question, but I'm trying to resolve the same problem on my MacBook - but for the life of me I can't find "more settings" anywhere on my TorGuard app? Not in the menu or on the app space itself.

Help?

 

Hi Anthony please follow my last post to resolve your problem.

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×