Jump to content
TorGuard
  • 0
djdeki21

Speed suffering!!

Rate this question

Question

hey guys i just purchased Torguard and im getting a HUGE loss in speed. i pay for a 100 mbps from my provider and im only getting 5-8 mbps at the very best when using Torguard. this is a BIG loss in speed that i cant bare. i have it hooked up through my router TP-Link AC1750 but i flashed DD-WRT on it, way better than stock firmware. can anyone suggest which protocol and or setting i should be using to getting  maximum speed for my dedicated IP. any help would be grateful.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I am no expert but check your CPU clock frequency for that device.

I was using a cheap Asus router for a couple of years and maxed out at 10Mbps on a 200/100 fibre connection.

I have since invested in a Netgear Nighthawk X4S R7800 (1.7GHz. CPU max) with Kong DD-WRT and consistently achieve 60Mbps.

https://www.dd-wrt.com/phpBB2/viewtopic.php?t=289788

The point is that decrypting OpenVPN is very CPU intensive (and single core only...as far as I understand)

Hope this helps.

Share this post


Link to post
Share on other sites
  • 0
On 12/30/2017 at 10:13 AM, djdeki21 said:

hey guys i just purchased Torguard and im getting a HUGE loss in speed. i pay for a 100 mbps from my provider and im only getting 5-8 mbps at the very best when using Torguard. this is a BIG loss in speed that i cant bare. i have it hooked up through my router TP-Link AC1750 but i flashed DD-WRT on it, way better than stock firmware. can anyone suggest which protocol and or setting i should be using to getting  maximum speed for my dedicated IP. any help would be grateful.

 

Customer support is really good at fixing speed issues. They usually suggest doing the following when using the TORguard app

 

Please click more Settings-> Network on the VPN app 
Uncheck the block outside DNS box
Locate three drop downs under the " use these nameservers" section 
Choose Google under all three of them on by one
Click Save and restart App first

Try to Connect

Please connect with tunnel type as Open Connect and Protocol as UDP this time.

 

I recently changed ISP providers to also get 100/10 service and the same setting above were not working for me.

I kept google as the name servers and went back to tunneltype = OPENVPN, protocol UDP, port 1195(SHA 256) Ciper AES-256-CBC

The servers closest to me I was getting about 60-70 Mbps, if you in USA, the Chicago server seems to connect fastest for me I now get 108/11 when connected to torguard. Before I made changes my downloads would not get pass 20.

Try the first suggestion as this is what Torguard support usually recommends. 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
On 12/31/2017 at 2:55 PM, tordns said:

 

Customer support is really good at fixing speed issues. They usually suggest doing the following when using the TORguard app

 

Please click more Settings-> Network on the VPN app 
Uncheck the block outside DNS box
Locate three drop downs under the " use these nameservers" section 
Choose Google under all three of them on by one
Click Save and restart App first

Try to Connect

Please connect with tunnel type as Open Connect and Protocol as UDP this time.

 

I recently changed ISP providers to also get 100/10 service and the same setting above were not working for me.

I kept google as the name servers and went back to tunneltype = OPENVPN, protocol UDP, port 1195(SHA 256) Ciper AES-256-CBC

The servers closest to me I was getting about 60-70 Mbps, if you in USA, the Chicago server seems to connect fastest for me I now get 108/11 when connected to torguard. Before I made changes my downloads would not get pass 20.

Try the first suggestion as this is what Torguard support usually recommends. 

 

 

 

thanks for the info. i have a dedicated ip address. you may be talking about the shared server.

Share this post


Link to post
Share on other sites
  • 0
On 12/31/2017 at 11:55 PM, tordns said:

Please click more Settings-> Network on the VPN app 
Uncheck the block outside DNS box
Locate three drop downs under the " use these nameservers" section 
Choose Google under all three of them on by one
Click Save and restart App first

Try to Connect


...............

tunneltype = OPENVPN, protocol UDP, port 1195(SHA 256) Ciper AES-256-CBC

 

 

 

 

With these settings I'm getting a fast stable download speed. Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×