Jump to content
Company Name
  • 0
Sign in to follow this  
willetlinks

VPN App for Arch Linux 64 "Detection Failed"

Rate this question

Question

For about 2 months, the vpn client continuously states "detection failed" after the connection has been established. I installed 0.3.69 and it continued to fail. I usually do a dnsleak check of my own to verify everything is working properly. Is there an easy fix to this? I am using Linux 4.11.9-1-ARCH x86_64 (antergos).

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
On 10/2/2017 at 5:47 AM, Support said:

 

I'm glad to hear so :)

 

There's is a few fixes coming in our next build which is close to release.

 

Regards

 

The latest version 0.3.76 has detection feature working. (0.3.74 and 0.3.75 works as well) SOLVED

Share this post


Link to post
Share on other sites
  • 1

​I tried the test build you recommended in the other thread, torguard-v0.3.71-pre.42+g5b09ee3.dev-amd64-arch.tar.gz, and it worked! I also tried, torguard-v0.3.71-pre.51+ge080cd1.dev-amd64-arch.tar.gz and torguard-v0.3.71-pre.54+g3f0aaac.dev-amd64-arch.tar.gz, and they continued to work. It's great to see some progress.

 

I'm glad to hear so :)

 

There's is a few fixes coming in our next build which is close to release.

 

Regards

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

Can you try below and see if this clears up your problem ?

 
Please go to more settings --> Network Tab --> Set the DNS as below:
 
At Application Start: Level3
While establishing: Level3
When VPN is connected: Level3
 
Restart TG Client and retest.

Share this post


Link to post
Share on other sites
  • 0

 

Hello,

 

Can you try below and see if this clears up your problem ?

 
Please go to more settings --> Network Tab --> Set the DNS as below:
 
At Application Start: Level3
While establishing: Level3
When VPN is connected: Level3
 
Restart TG Client and retest.

 

 

I tried the above but same results. I would also like to add that I uninstalled the client app and deleted the VPNetworkLLC folder in .config in order to reset the settings and tried again. Still same results.

Share this post


Link to post
Share on other sites
  • 0

I have the same issue on Arch, TorGuard x64 v0.3.68 - v0.3.70

 

Can you guys try set them all to "none" and retest ?

 

At Application Start: none

While establishing: none
When VPN is connected: none
 
We have very few clients with the issue but vast majority don't have any problems so we are trying to find the cause.
 
Regards

Share this post


Link to post
Share on other sites
  • 0

​

​

​

 

 

Can you guys try set them all to "none" and retest ?

 

At Application Start: none

While establishing: none
When VPN is connected: none
 
We have very few clients with the issue but vast majority don't have any problems so we are trying to find the cause.
 
Regards

 

Tried with all set to none and tried with my own added DNS servers, both did not work. I also noticed an error in terminal, not sure if it is related:

 

HTTP request failed: "Error creating SSL context (error:140A90C4:SSL routines:func(169):reason(196))"

Share this post


Link to post
Share on other sites
  • 0

​

​

​

 

Tried with all set to none and tried with my own added DNS servers, both did not work. I also noticed an error in terminal, not sure if it is related:

 

HTTP request failed: "Error creating SSL context (error:140A90C4:SSL routines:func(169):reason(196))"

 

Would it be possible to send you a text build to see if this works ?

 

Regards

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Would it be possible to send you a text build to see if this works ?

 

Regards

 

​I tried the test build you recommended in the other thread, torguard-v0.3.71-pre.42+g5b09ee3.dev-amd64-arch.tar.gz, and it worked! I also tried, torguard-v0.3.71-pre.51+ge080cd1.dev-amd64-arch.tar.gz and torguard-v0.3.71-pre.54+g3f0aaac.dev-amd64-arch.tar.gz, and they continued to work. It's great to see some progress.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×