Jump to content
TorGuard

adagari

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About adagari

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. adagari

    Wireguard support?

    I am interested in wireguard support as well.
  2. adagari

    Openconnect - Setup with openwrt router

    Hello, Yes there does seem to be an issue using the direct IP. On a reboot openconnect fails to reconnect. I have reverted back to openvpn for the time being.
  3. adagari

    Openconnect - Setup with openwrt router

    Hello, I built a new openconnect package and installed the ca-certificates package, but it still resulted in the same error. Are the certificates self signed? This may be the issue with trying to setup on LEDE. It seems the only way I can get openconnect to work is by 1.) run "gnutls-cli --insecure hostname:port" 2.) enter the IP and sha1 key id returned in my LEDE config. Doing this allows me to connect to the host. Although it might not be ideal because I will connect to the same IP each time.
  4. adagari

    Openconnect - Setup with openwrt router

    Hello, I checked and I do not have the ca-certificates package installed. Right now I am in the process of setting up openconnect again. I will report back with my findings.
  5. adagari

    Openconnect - Setup with openwrt router

    Hello there, Here is my log with openconnect setup. https://pastebin.com/Z1WEQaHy Here is another log with the --no-cert-check argument passed. https://pastebin.com/eCudEVg5 I am assuming this may be an issue with the certificate authority used to sign the certificates. Usually, you could pass --servercert sha1:## to trust the certificate but this creates an issue where when you connect to the hostname, it is a different server, with a different certificate, each time.
  6. adagari

    Openconnect - Setup with openwrt router

    Hello Yann, I recently submitted a bug report to the LEDE project about the broken package. It should be available in th currently night builds. In addtion, the torguard server certificates do not seem to be configured correctly. You will receive errors when trying to connect which can no longer be fixed by the depreciated command --no-cert-check. Basically, at this time don't bother with openconnect until torguard finds a solution to the certificate issue.
×